center
 
Language
 |

Overlord: Fellowship of Evil (2005)

Overlord: Fellowship of Evil
Category:
Themes:
Platform:
NOTA JOC & opinions
0
vot0 vote
com 0 opinions
view 383 views
Give yourself a note
He contributed to the game details :

Overlord: Fellowship of Evil System requirements

 
 »Minimum System Requirements:
 »Recommended system requirements:
INTEL PROCESOR
Core 2 Duo E4600 2.4GHz
Core i5-650 3.2GHz
AMD PROCESOR
Athlon 64 X2 Dual Core 5400+
FX-4100
AMD GRAPHICS
Radeon R9 270
RAM
2 GB
4 GB
OS
Win Vista 32
Win 7 64
Directx
DX 10
DX 11
HDD
4 GB
4 GB
He contributed to system requirements :

Images Overlord: Fellowship of Evil Add images

avatar
To answer a question you need to have an account on optigames.net



This message only appears a few times, so give it to us now !
Send on : fb Facebook