center
 
Language
 |

Lords of the Fallen: Ancient Labyrinth (2015)

Lords of the Fallen: Ancient Labyrinth
Themes:
Platform:
Developer:
CI Games
NOTA JOC & opinions
0
vot0 vote
com 0 opinions
view 5717 views
Give yourself a note
He contributed to the game details :

Lords of the Fallen: Ancient Labyrinth System requirements

 
 »Minimum System Requirements:
 »Recommended system requirements:
INTEL PROCESOR
Core 2 Quad Q8400 2.66GHz
Core i7-3770K 4-Core 3.5GHz
AMD PROCESOR
Phenom II X4 940
FX-8350
AMD GRAPHICS
Radeon HD 6850
Radeon HD 6950
RAM
6 GB
8 GB
OS
Win Vista 64
Win 7 64
Directx
DX 11
DX 11
HDD
25 GB
25 GB
He contributed to system requirements :

Images Lords of the Fallen: Ancient Labyrinth Add images

avatar
To answer a question you need to have an account on optigames.net



This message only appears a few times, so give it to us now !
Send on : fb Facebook